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1. Introduction

The LED Single Line Moving software is developed by our company as a manage software of Single Line LED Electronic Message Center. This section will depict the content such as following:
· Software function
· Software feature

· Run environment

1.1 Software Function
This program will create files containing all appropriate controls and messages necessary to operate the Sign including the following main functions:

· Input/Edit text with standard characters, 66 international characters, date and time.

· Input/Edit graphics and their controls.

· Embed control characters’ for fonts, color, sounds and display scheduling.

· Embed controls for message display modes, move speeds, pause time, etc..

· Modify all sign operation controls and message contents.
· Upload and Download messages and controls to/from the Sign.

· Turn on/off moving-sign
· Test the dark dot in Sign
· Clear Sign’s memory

· Sequencing multiple messages display
1.2 Software Feature
· Interface of the managing software can be in multiple languages 
· Color: single color, double color, base color. 
· Figure operation interface (What You See is What You Get) 
· Appearance size: according as user’s need to adjust.

· Supports picture type: BMP.
· Control method: asynchronism control

· Communication method: Serial data port communication, network, Modem.
· Protocol type: simply serial data port communication protocol.
1.3 Running Environment
Following give this software running requirement:
Minimum PC System Requirements:

OS: WIN9X/2K/XP

Processor: Pentium200, 1GHz or up.

RAM: 32MB or up.

Hard Disk: 100MB hard disk space or up.
Display mode: 800
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Display memory: 2MB or up
Color: 16 or 24 or 32 bit colors.

Network: 10M TCP/IP port.
2. Operation 
    If you want to use a software, you must install the software on computer. This software is needn’t setup for running. User only needs insert the CD of the software into your CD disk drive and copy it to your disk. Then double click left key of mouse on the software icon on the desktop to run it.
This section is includes:
· Setting 
· Main window introduction

· Menu introduction
· Operation process
2.1 Setting 
Copy the control software from CD to your hard disk. Double click mouse left to run this software. Then it will display a figure window as following:
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Parameter meaning:
· Size:
Width: the Moving-Sign’s width, unit: pixels.

· Color:
Monochrome: The Moving-Sign can display red only. 
Bi-Color: The moving sign can display tri-color including Red, Green and Yellow which is composed of Red and Green two basic colors. 
After set the parameter, click OK button to confirm. 
2.2 Main Window Introduction
The software has friendly operation interface. User can operate it very easy. When you run the software and setting the Moving-Sign’s parameter, there will a main frame for you to manage the Multi-Lingual moving sign. 
Following contents will introduce the main window.
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The main window includes title bar, menu bar, tool bar, status bar, text work area and control panel. Following we will give a simply introduction of them.
1. Title Bar
Title column is display the current title information. 
2. Toll Bar
Tool bar includes many tools for editor message. In next part we will depict it.

3. Menu Bar
Menu bar includes kinds of operation option. There are ten kinds menu: file menu, insert menu, scheduler and special function menu, user-defined bitmap menu, send menu, communication setting menu, and about menu. Those menus have their submenu too.
4. Status Bar
Status bar is display some subjoin information such as screen number of the cursor, ready and so on. 
5. Message Workspace
Message Workspace is used for editing message file.

The LED Single Line Moving-Sign software has many other windows. In the following contents we will introduce them stepwise. 
2.3 Main Menu Introduction

This part described the main menu of this program. It includes following contents:
· File menu

· Insert menu

· Scheduler and Special Function menu
· User-defined Bitmap menu

· Send menu

· Communication setting menu

· About menu

2.3.1 File menu 
    Click mouse left key on the File it would be a submenu as fig2.3 shows.

File includes some submenu: Language, New, Open, Save, Save as, Exit.
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2.3.1.1 Language 

Select language which user wants to set for interface.

Click mouse’s left-key on Language, it would be a dialog box as fig2.4 shows. User can use this submenu to switch the language of the program interface to another one. 
Select one language from list box and then press OK button; the language of program’s interface will be changed to this language. About how to make a native resource, please refers to section 3.4 How to Change language of Program. 
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2.3.1.2 New 

    Create a new message workspace. 
Click ‘New’ command under file menu or [image: image2.png]


 button in toolbar to execute it. If there are content in currently active message workspace, it will warn you to save the file.
2.3.1.3 Open 

Open an existing file.

User can use the menu to open an old file that has saved in the disk. Click mouse’s left-key on ‘Open’ command, it would be display a dialog box. You can browse the file that has saved in disk and select one to open. Then you can edit it or send it to moving sign. This menu has a shortcut button [image: image3.png]


 in toolbar. 
2.3.1.4 Save 

Save the active file.

Click mouse’s left-key on ‘Save’ command in the file menu. It will save the contents of currently active message Workspace in the open file. This menu has a shortcut button [image: image4.png]


 in toolbar. 
2.3.1.5 Save as 

Save the active file with a new name.

Click mouse’s left-key on ‘Save as’ in the file menu. It will save the contents of currently active message Workspace in a new file. 
2.3.1.6 Exit

Quit the application and prompts save the file. 
Exit this program. If user selects the option, there would be a warning dialog box to prompts save the file. 
2.3.2 Insert menu 
Click mouse’s left key on the Insert, it would be a submenu as fig2.5 shows.

This menu includes some submenu: New Message, Transition Effects, Time, Date, Pre-Defined Symbols, User-Defined Bitmaps, Pre-Defined Bitmaps, Special Characters, Cartoon, Beep, Speed, and Pause.
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2.3.2.1 New Message
Add a new message to message workspace.
Click ‘New Message’ command to execute this function. There will display “Msg **” in the “Message Workspace”. It means a new message’s start.
2.3.2.2 Transition Effects
Insert transition effects to control message how to move in.
Click mouse’s left-key on ‘Transition Effects’ command under insert menu to execute it. It will display a dialog box as fig2.6.

Select a desired transition effect from list box in below dialog box. Then click ‘Insert’ button to insert the transition effect. Click ‘cancel’ button to cancel the operation. There are 25 kinds move method.
[image: image30.png]Send  Communication Settings  About

Send current messags workspace contents
Send Saved Data Fk.

Run Test Sequence

Clear Sign's Memory





2.3.2.3 Time
Insert time to display on the electronic center.
Click ‘Time’ command to execute this function. There will display the current time in the “Message Workspace”.

2.3.2.4 Date
Insert date to display on the electronic center.

Click ‘Date’ command to execute this function. There will display the current date in the “Message Workspace”.
2.3.2.5 Pre-Defined Symbol
Insert pre-defined symbol into Message.
Click ‘Pre-defined Symbol’ command to execute this function. It will display a dialog box as fig2.7.

Select the desired symbol in below dialog box by click mouse’s left-key on the symbol. The symbol will change the color when it is clicked (In the fig, it has selected the “car”.). Then click ‘OK’ button to insert the selected symbol or click ‘Close’ button to close the dialog box. 
There are 30 type pre-defined symbols. 
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2.3.2.6 User-Defined Bitmaps
Insert the user-defined bitmap image into message.
Click ‘User-Defined Bitmaps’ command to execute it. User must first load an image transfer file before you can select images to insert into your message. If you don’t load, a warning dialog box will be displayed to warn you. Click ‘OK’ button to confirm and another dialog box will be displayed for you select user-defined bitmap image to insert.
Note:

The user-defined bitmaps List used by user in message workspace must be the same as the List be sent to Moving Sign, so that Moving Sign can display correct user-defined bitmaps.
2.3.2.7 Pre-Defined Bitmaps 
Insert pre-defined bitmap image into message. 
Click ‘Pre-defined Bitmaps’ command to execute this function. It will display a dialog box as fig2.8.

Select the desired pre-defined bitmap image in below dialog box by click mouse’s left-key on the image. The will change the color when it is clicked (In the 

fig, it has selected the “ship”.). Then click ‘OK’ button to insert the selected image, or click ‘Close’ button to close the dialog box. 

There are eight type pre-defined bitmap images. 
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2.3.2.8 Special Characters 

Insert special characters into message.
Click ‘Special Characters’ command to execute this function. It will display a dialog box as fig2.9.

Select the desired special characters in below dialog box by click mouse’s left-key on the character. It will be lapped by a green rectangle when it is clicked (In the fig, it has selected the “Ç”.). Then click ‘OK’ button to insert the selected character, or click ‘Close’ button to close the dialog box. 

There are 66 type special characters.
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2.3.2.9 Cartoon 
Insert cartoon control into message workspace.
Click ‘Special Characters’ command to execute this function. It will display a dialog box as following fig.
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Select the desired cartoon in above dialog box by click mouse’s left-key on the name of cartoon. Then click ‘OK’ button to insert the selected cartoon, or click ‘Cancel’ button to close the dialog box. 

There are eight type cartoons.

2.3.2.10  Beep 

Insert beep controls into the message workspace.
Click ‘Beep’ command to execute this function. It will display a dialog box as following fig.
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Select the desired type beep in above dialog box by click mouse’s left-key on the beep. Then click ‘OK’ button to insert the selected beep, or click ‘Cancel’ button to close the dialog box. 

There are three type cartoons.

2.3.2.11  Speed 

Insert speed control into message workspace.
Click ‘Speed’ command to execute this function. It will display a dialog box as following fig.
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Select the desired speed in above dialog box by click mouse’s left-key on the speed. Then click ‘OK’ button to insert the selected speed, or click ‘Cancel’ button to 


close the dialog box. 

There are eight speeds. Speed 1 is the fastest speed, speed 8 is the slowest speed and speed 3 is the default speed.
2.3.2.12  Pause 

Insert pause control into message workspace.

Click ‘Pause’ command to execute this function. It will display a dialog box as following fig.
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Select the desired pause in above dialog box by click mouse’s left-key on the pause. Then click ‘OK’ button to insert the selected pause, or click ‘Cancel’ button to close the dialog box. 

There are eight type pauses. There are pause 2 second, 3 second, 4 second, 6 second, 10 second, 20 second, 30 second, 60 second. 

2.3.3 Scheduler and Special Functions Menu
This menu can setting for Scheduler, Alarm, Hourly Alarm, Power ON, Power Off and Time Setting.

Click mouse’s left key on the Scheduler and Special Functions, it would display a dialog box as fig2.14 shows.

This menu includes many options such as Scheduler, Alarm, Hourly Alarm, Power ON, Power Off and Time Setting.
In following content, we will introduce these commands one by one. 
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2.3.3.1 Scheduler
Set the schedule task.
· Task: Which timer is set up (10 timers exist.). User can select a task from drop list box to set. 

· Start time: Start time of schedule task.

· End time: End time of schedule task.

· Run date: In which day of a week the schedule task can run. Many days can be set up running.

· Files included in task: The message name of running message in set time. All set messages must be stored in the Moving Sign. For example: The user want to set "Msg 01"and"Msg 02"to run from 8:20am to 5:00pm in Monday and Tuesday in every week, use the second timing equipment. Then on scheduler column, set 02.In "Start time" item, input 08 and 20.In "End time" item, input 17 and 00.In "Run Date" item, choose Monday and Tuesday. In Setting file name Item, first choose “Msg 01” in ‘All files’ list box , and then press button ‘Add’ or double-click mouse’s left-key to add this message to ‘Files in task’ ,second use the same operation to “Msg 02” to add “Msg 02” to ‘Files in task’.
One message can be inserted into ‘Files in task’ list box more than one times .The order of file display in ‘Files in task’ list box is the order of file display in sign. User can press button ‘Up’ and ‘Down’ button to change the file’s order. 
User can remove a message from ‘Files in task’. First, select the message’s name in ‘Files in task’, then click ‘Remove’ button to remove it. 
2.3.3.2 Alarm 
Click ‘Alarm’ option, it will display following property page.
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· "Number of times to alarm" can set the total times of ring alarm.
· "Interval between each alarm" can set the interval of each two ring alarm, the unit is minute. 
2.3.3.3 Hourly Alarm
Set hourly alarm ON or OFF.
Click ‘Hourly Alarm’ option, it will display a property page as similar as fig2.15. 
User can turn ON/OFF the hourly alarm by click [image: image5.png][~ Bt hourly alarm ON



 button. 

· means ON
· means OFF

2.3.3.4 Power ON
Set the time of automatically turn on the Moving-Sign.
Click ‘Hourly Alarm’ option, it will display a property page as similar as fig2.15.
User can input the time of automatically turn on the Moving-Sign in [image: image6.png]@ ~]m oo vlm oo v]ss



 box. Then click ‘OK’ button to confirm.
2.3.3.5 Power OFF
Set the time of automatically turn off the Moving-Sign.
Click ‘Hourly Alarm’ option, it will display a property page as similar as fig2.15.

User can input the time of automatically turn off the Moving-Sign in [image: image7.png]@ ~]m oo vlm oo v]ss



 box. Then click ‘OK’ button to confirm.
2.3.3.6 Time setting

Set the sign’s time and date to same with computer. 

Click ‘Time setting’ option, it will display a property page as similar as fig2.15.

User can choose 12-hour mode or 24-hour mode at the same time by click [image: image8.png](¢ 12-Hour!



 or [image: image9.png]" 24-Hour



 button. 
Note: 

These setting data for special file ,alarm, hourly alarm, power on, power off, time settings are saved with *.SDV disk file.

2.3.4  User-Defined Bitmap Menu
Click mouse’s left key on the User-Defined Bitmap, it would be a submenu as fig2.16 shows.

The menu includes some submenu: Load File, Open workspace, Open Catalog.
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2.3.4.1 Load File
Change image transfer file to use bitmap image in another image transfer file.
Change Graphic List (*.LST) connected to *.SDV.(Normally, the user connected a Sending file (*.SDV) with a graphic list file (*.LST), choose this function to connect the sending file (*.SDV) with another graphic list file (*.LST) the user want to change.)
Normally, the sign can store 8 pcs user-defined bitmap, if user have more than 8 pcs, user can create all these bitmaps in section 2.3.4.2 Open Workspace, and then create some groups according needs in section 2.3.4.3 Open Catalog, each group can maxim store 8 pcs bitmap. At last, if user want use some user-defined bitmap in a certain group, execute this menu to load the corresponding group and then insert one or more bitmap in this group to text file.
2.3.4.2 Open Workspace
Create a new window to create a bitmap.
User-Defined bitmap disk file must be placed in the same directory with this software. The naming rule for user-defined bitmap disk file is: start with E1000Pic, follow on the heels of it is the moving-sign’s width and its color (characters S mean the sign is monochrome, character D mean the sign is BI-color). For example, E1000Pic_80_S.dat: it is mean this file is a user-defined bitmap disk file for E1000 series sign, sign’s width is 80 pixels, color is monochrome. Program will load these user-defined bitmap data automatically when program startup.

Let the user create 7(80 (Height(Width) Pixels graphic for special use with maximum 5000 pcs graphics (Saved in the current directory of the Moving Sign management software), and the user can use maximum 8 pcs graphics at one time in the Moving Sign.
Click mouse’s left-key on ‘Open workspace’ command under User-defined Bitmap menu to execute it. Then a window will be display as following fig.
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· 【1】Palette: Palette for user creates bitmap image. Click mouse’s left-key on the color to choose it. And there is a ‘cross’ in the middle of the chosen color.
· 【2】Graphic area: Click mouse’ left-key or press it and moving to make image. Click mouse’ right-key or press it and moving to clear.
· 【3】Preview: Preview the image is as same as the content in the message workspace.
· 【4】The number of the image that is being edited current.
· 【5】The total numbers of images that had been defined by user.
Note:
    The software saved the current bitmap automatically.
Now, introduce the menu of this window. This window has two main menu: File menu and Bitmap menu.
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File menu
File menu include some sub-menu. Click this menu, it will display a submenu as following fig. They are ‘Save as’, ‘Open Catalog’, and ‘Exit(ESC)’. 








· Save as: Save the current edit lattice as a new file name.
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Open Catalog: There is a dialog box displaying as follows:

















Operation the dialog box information:
“Bitmap Image Catalog”: the area display all images by user defined. The maximum is 5000pcs.
“Contents of Bitmap File”: the area display the images that user want to use in the Moving-Sign at one time. User can load the image into this area by double click mouse’s left-key on the image in “Bitmap Image Catalog” area. The maximum is 8pcs.
“Remove” button: remove an image from “Contents of Bitmap File”. First select an image in “Contents of Bitmap File” by click it, then click “Remove” button to delete it.
“Save Bitmap File” button: click this button to save “Contents of Bitmap File” as a disk file (
[image: image10.wmf]*

.LST).
“Save AS…” button: click this button to save “Contents of Bitmap File” as another name disk file (
[image: image11.wmf]*

.LST).
“Open Bitmap File” button: click this button to choose an existed disk file (
[image: image12.wmf]*

.LST) and open it. 
“New Bitmap File” button: click this button to create a new bitmap file.
“Clear Bitmap File” button: click this button to clear all image in “Contents of Bitmap File”.
“Close” button: click this button to close this dialog box.
· Exit(ESC): Click this command or Esc key of keyboard to exit the window.
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Bitmap
Bitmap menu include a sub-menu. Click this menu, it will display a sub-menu as following fig. They are Create a new bitmap image, Open existing bitmap image, Clear this workspace, Remove current bitmap image from catalog. 






· Create a new bitmap image: Execute it to create a new bitmap image.
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Open existing bitmap image: Open a edited image to re-edit. Execute the sub-menu, it will display a dialog box as following.









Input the number of the image that you want to edit in text box. Then click ‘OK’ button to confirm. And the image will be open.
· Clear this workspace: Clear the current “Graphic area”.

· Remove current bitmap image from catalog: Remove current bitmap image file.

· How to transmit the lattice data to sign
User must first create one bitmap file follow above introduced, then select menu “Insert >User-defined Bitmaps” to insert this bitmap file to text file. Program will transmit these bitmap image data in this bitmap file to sign when user transmit text file data to sign.
2.3.4.3 Open Catalog
Create new or edit user-defined bitmap file list.
Click ‘Open Catalog’ command to execute it. It complete the function is as same as “File > Open Catalog” menu of bitmap image workspace (fig2.17) in section 2.3.4.2 Open Workspace. 
2.3.5 Send Menu
Click mouse’s left-key on the Send, it would be a submenu as fig2.22 shows.

The menu includes some submenu: Send current message workspace contents, Send Saved Data File, Run Test Sequence, and Clear Sign’s Memory.
[image: image46.png]Device Settings

Available Devices

[BAIL ey Davies
Edit Davice
Renove Device
Renspe Device
Meke Default





2.3.5.1 Send current message workspace contents
Transmit the current message workspace’s contents to Electronic Message Center. 
Click on ‘Send current message workspace contents’ command or [image: image13.png]


 button in toolbar to execute this function.

2.3.5.2 Send Saved Data File 
Load a disk file(
[image: image14.wmf]*

.SDV) to message workspace and transmit it to Electronic Message Center. 
    Click ‘Send Saved Data File’ command under send menu. It will display a dialog box for user to choose disk file(
[image: image15.wmf]*

.SDV) from disk.
2.3.5.3 Run Test Sequence
Check dark dot in Electronic Message Center.
    Click ‘Run Test Sequence’ command under send menu to execute it. It will send a command to let all LED dots of moving-sign light, so user can check whether the moving-sign have some dots that can’t light.
2.3.5.4 Clear Sign’s Memory
Clear all contents in Sign’s Memory.
Click ‘Clear Sign’s Memory’ command under send menu to execute the function, it will transmit a command to Sign and clear all contents in Sign’s memory.
2.3.6 Communication Settings Menu
Click mouse’s left key on the Communication Settings, it would be a submenu as fig2.23 shows.

This menu includes some submenu: TCP/IP Group Settings, MAIL SERVER Settings, Mailbox Settings, Device Settings, Site Settings, Group Settings, Modem, and Info.
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2.3.6.1 TCP/IP Group Settings 
Edit Server IP address.
This sub-menu allows you to connect one or more signs to a Local Area Network(LAN) using Ethernet Adapters.

Before you can transmit messages to Signs by Local Area Network(LAN), you must configure Ethernet Adapter correctly. Please refer to NetJetSetting manual to learn about how to configure Ethernet Adapter.

Click ‘TCP/IP Group Settings’ command to execute this menu command, it will display a dialog box as follows:
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“New TCP/IP Group” button
Click this button to create a new TCP/IP group. When execute the function, it will display a dialog box as following:







Input the new group’s name. Purpose of “Group’s name” is just easy manage (or remember) the IP address. The example is input “GRP01” for group’s name. Then click ‘OK’ button to confirm. Another dialog box will be displayed as following fig.






IP address: Specify the 4-node Internet Protocol address for the Ethernet Adapter connected to Sign to which you will talk. Ask your network administrator if you don’t know this address. Then click ‘OK’ button to confirm, and “Group’s name <=> IP address” (this example is “GRP01 <=> 192.168.1.10”) will be displayed in “Available TCP/IP Groups” box as fig2.24.
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“Edit TCP/IP Group” button
Edit existing TCP/IP group in “Available TCP/IP Groups” box. First select a group, then click ‘Edit TCP/IP Group’ button, it will display a dialog box to change the IP address as following. Lastly, click ‘OK’ button to confirm.








· “Remove TCP/IP Group” button
Select a group from “Available TCP/IP Groups” box, then click this button to remove the selected TCP/IP Group.

· [image: image52.png]'® Message Central




“Rename TCP/IP Group” button
Change TCP/IP group’s name. Select a group from “Available TCP/IP Groups” box, and click this button. It will display a dialog box as following. User can rename in the dialog box. Lastly, click ‘OK’ button to confirm.







· “Close” button
Close this dialog box. 
2.3.6.2 MAIL SERVER Settings 
Set mail server that used to send message to Electronic Message Center by internet.
If user wants to control signs through Internet, user must select this menu to add at least one mail server through which program will send mail. Following content will introduce how to set a mail server.
Click ‘MAIL SERVER Settings’ command under communication settings menu to execute the command. It will display a dialog box for setting MAIL SERVER as following fig shows.
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“New Mail Server” button
Create a new Mail Server. Click this button, a dialog box will be displayed as fig2.30. Please input the name of Mail Server (Name is an ID to identify each SMTP(Simple Message Transfer Protocol) server. User can name it at will, but this name should be not repeated.). Then click ‘OK’ button to confirm. And another dialog box will be displayed as fig2.31.


























Some ISP want to user login on incoming server before send mail, so user must input the information for POP server.
Internet mail address: Input the mail address, program will use this mail address to send e-mail.
POP3 SERVER: Input the POP3 server’s name in the text box, such as POP.163.com.
POP3 Account: Input the mail account which you want to use it to send mail.
Password: the password for the POP3 Account.
Server port for POP3: Input the POP port in the text box, the default value is 110.
SMTP Server: Input the SMTP Server’s name or IP in the text box, such as: smtp.163.com.
Server port for SMTP: Input the SMTP port in the text box, the default value is 25.
SMTP server needs AUTHENTICATION: Some SMTP server needs authentication, and other needn’t, so if the SMTP Server needs authentication, user must select this check-box and press SETUP button to input the Account and Password as follow: 
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Normally, the Account and Password are same with POP3 Server. If the account and password is not same with POP3 Server, please check “Authentication information” and input the account and information. If user doesn’t know these parameters, please ask the network administrator.
Note: The MAIL SERVER must support SMTP and POP3 protocol.
These setting data is saved in E1000SiteManage.dat file, this data file is placed in the same directory with this program. If user want re-use this data in another computer, user can copy this file to another computer and place this file in the same directory with this program.



· “Edit Mail Server” button
Edit the available Mail server. First select a mail server from “Available Mail server” window. Then click this button, it will display a dialog box as similar as fig2.31. User can edit the selected mail server.
· “Remove Mail Server” button
Select a mail server from “Available Mail server” window, and click this button to remove it.
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“Rename Mail Server” button
Change the mail server’s name. Select a mail server from “Available Mail server” window, and click this button. It will display a dialog box as following fig.







Input the new name and click ‘OK’ button to confirm.
· “Close” button
Close this dialog by click ‘Close’ button.
2.3.6.3 Mailbox Settings 
Set the mailbox address which will receive email.

Click mouse’s left-key on ‘Mailbox Settings’ command under communication settings menu to execute it. A dialog box will be displayed as following fig.
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“New Mailbox” button
Use this button to create a new mailbox. When click this button it will display a dialog box as following fig.







Input the new mailbox’s name and click ‘OK’ button to confirm. Then another dialog box will be displayed as following:







Input the address of the new mailbox, and click ‘OK’ button to confirm.
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“Edit Mailbox” button
Edit the available mailbox. First select a mailbox from “Available Mailbox” window, then click this button. It will display a dialog box as following fig.







User can edit the address of the selected mailbox, then click ‘OK’ button to confirm.
· “Remove Mailbox” button
Select a mailbox from “Available Mailbox” window, and click this button to remove it.
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“Rename Mailbox” button
Change the mailbox’s name. Select a mailbox from “Available Mailbox” window, and click this button. It will display a dialog box as following fig.







Input the new name of the selected mailbox and click ‘OK’ button to confirm it.
· “Close” button
Close this dialog by click ‘Close’ button.
Note: 
These setting data is saved in set.ini file, this ini file is in the same directory with this program. If user want re-use this data in another computer, user can copy this file to another computer and place this file in the same directory with this program.
2.3.6.4 Device Settings 
Create new or edit an existing device.
A “Device” is a way to connect a sign to a PC that is running this program.
The category of device include: COM Port (Cable connection), Modem connection, TCP/IP (Local Area Network) connection, Email (Internet) connection. In other words, user can send message to sign through COM Port, modem, TCP/IP (In Local Area Network), Email (in Internet). If user want use a certain device, user must first create this device.

Click mouse’s left-key on ‘Device Settings’ command under communication menu to execute it. A dialog box will be displayed as following fig.
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“New Device” button
Create a new device. Click this button, it will display a dialog as following:







Input the name of device and click ‘OK’ button. Another dialog box will be displayed as following:
















If user wants to add COM Port device, un-select Modem, TCP/IP and Email Poller, and select the COM Port and the baud rate(the default baud rate for E1000 series sign is 2400 bps, if user select the other baud rate will cause send message failed!). Then click ‘OK’ button to add COM Port device.

If user wants to add modem device, un-select TCP/IP, Email Poller and select Modem. If the modem is external modem, user can connect the modem to computer’s COM port and use it directory, check External Modem radio button and select the COM Port, baud rate. If the modem is internal modem, user must install the window’s driver for this modem, and check Internal Modem radio button and select this modem in combo list box. The dial-up time out is set the time out when dial-up.

If user wants to add TCP/IP device, un-select Modem, Email poller and select TCP/IP. Specify the IP port and the time out when connect.

If user wants to add Email device, un-select Modem, TCP/IP and select Email poller. Select the SMTP SERVER. About how to add SMTP SERVER, please refer to section 2.3.6.2 Mail Server Settings.
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“Edit Device” button
Re-edit the device. Select a available device from “Available Devices” window, then click this button. A dialog box as similar as fig2.41. User can edit the device in the dialog box.
· “Remove Device” button
Select a device from “Available Devices” window and click this button to remove it.
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“Rename Device” button
Select a device from “Available Devices” window and click this button. A dialog box will be displayed as following:







Input new name for the selected device and click ‘OK’ button to confirm.
· “Make default” button
Set the default device to communication. First select a device that you want to make default from “Available Devices” window, then click this button to set it as the default device.
· “Close” button
Close this dialog box by click ‘Close’ button. 
2.3.6.5 Site Settings
Create new or edit existing site.
Sites and Groups are terms used by this program to describe how messages are sent to signs. You create Sites and Groups to make sending messages to multiple signs flexible and easy.

A Site is a collection of one or more signs.
Click mouse’s left-key on ‘Site Settings’ under communication menu to execute it. A dialog box will be displayed as following:
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“New Site” button
Create a new site. Click this button, it will display a dialog box as following: 







Input the site’s name in the text box of above dialog box. Click ‘OK’ button, another dialog box will be displayed to specify the parameters for site as fig2.45. In the dialog box, select one device as the connect device for the new site in “Connect Device”, input character strings as the address list, last press button “OK” to create this new site.


If the connect device for site is modem, you should specify the phone number.

If the connect device for site is TCP/IP, you should specify TCP/IP Group name. About how to create a new TCP/IP Group, please refer to section 2.3.6.1 TCP/IP Group Settings. 

If the connect device for site is Email Poller, you must specify the receive mail address. About how to add a new receive mail address, please refer to section 2.3.6.3 Mailbox Settings.











Remark: If the sign 1# and sign 2# are placed in R&D ,and two signs are connect to computer ‘s COM Port with cable directory ,now if you want to send message to two signs at the same time, you should create a site, assume the site name is ‘R&D’. The create process is as following fig2.44 and fig2.45.
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“Edit Site” button
Re-edit the existing site. Select a desired site from “Available Sites” window, then click this button. And a dialog box as similar as fig2.45 will be displayed. User can change the setting in the dialog box.
· “Remove Site” button
Use this button to remove an existing site from “Available Sites” window. 
· “Rename Site” button
Use this button to change a site’s name. Select a desired site from “Available Sites” window, then click this button. And a dialog box as similar as fig2.44 will be displayed. User can input the new name in here.
2.3.6.6 Group Settings
Create new group or edit existing group.

A Group is made up of one or more Sites.

If you send message to more than one site, you should create one group and include these sites in this group. Click ‘Group Settings’ command under communication settings menu to execute it. A dialog box will be displayed as following fig.
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“New Group” button
Create new group. Click this button, it will display a dialog box as following:







Input the group’s name and click ‘OK’ button. And another dialog box will be displayed as fig2.48. In the dialog box, select site from “All sites” window, then click ‘Include Site’ button to add a site to the group. Or select site from “Sites in this group” window, then click ‘Remove Site’ button to remove a site from this group. Lastly, click ‘OK’ button to confirm create a new group.
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· “Edit Group” button
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Re-edit the existing group. First select a group from “Available Groups” window, then click this button. It will display a dialog box as similar as fig2.48 shows. User can add or remove site for the selected group.
· “Remove Group” button
Use this button to remove an existing site from “Available Groups” window.
· “Rename Group” button
Use this button to change a group’s name. Select a desired group from “Available Groups” window, then click this button. And a dialog box as similar as fig2.47 will be displayed. User can change the name in the dialog box. 
2.3.6.7 Modem Info
Check the modem.

Click mouse’s left-key on ‘Modem Info’ command under communication settings menu to execute it. A dialog box will be displayed as following:
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If there have installed modem, you can select one modem from “Installed Modem(s)” to see its detailed information.
2.3.8 About menu
Click mouse’s left key on the About, it would display a command as [image: image17.png]About Message Central,



. User click this command, it will display a dialog box include program information, version number, and copyright as following fig.
[image: image74.png]‘About Message Central

Version 3.49
fugust 01, 2008





2.4 Operation Process 
In front content, user knows this program familiar. In this part, we will introduce the general operation process. 
How to create message and communication with Moving-Sign? It must accord as diversified requirements to set. But following content will give you some help.
Following fig is the flow chart of general operation process.
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3. Appendix 
3.1 Right-key menu
When user is editing message in the Message workspace, you can click mouse’s right-key to accomplish some function quickly. If you click the right-key, it will display a menu as following fig. 
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3.2 How to delete a Message
If you want to delete a message, move the mouse to “Msg 
[image: image18.wmf]**

” before the message, then click mouse’s right-key, a menu will display as follow:
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From the menu, choose "Delete File" to delete the message. If the user wants to combine a message with the next message, choose "Combine File".
3.3 Example for how to send message to Sign 
Now assume there are three sign, these signs’ address is 1, 2, and 3. Sign 1# and sign 2# are placed in R&D, sign 3# is placed in Sales Department, the computer that is running this program placed in R&D, sign 1# and sign 2# are connect to PC’s COM port(COM1) , sign 3# is connect to Local Area Network. If you want to send message to Sign 1#, Sign 2# or Sign 3#, or send message to all these signs at the same time, you can do it as follow steps:

1. Select menu “Communication Settings>New/Edit Device” to create a new COM Port device, assuming the name for this device is “COM1”. Select “COM1” in COM Port list box and 2400 in baud rate in fig2.41.

2. Select menu “Communication Settings>TCP/IP Group Setting” to create a new TCP/IP group “Sales-IP”, input the IP address “192.168.0.12”.

3. Select menu “Communication Settings>New/Edit Device” to create a new TCP/IP device “TCP/IP-Sales”. Input “5005” as the IP Port.

4. Select menu “Communication Settings>New/Edit Site” to create a new site “R&D, select “COM1” as the connect device, input “1, 2” in address list.

5. Select menu “Communication Settings>New/Edit Site” to create a new site “Sales”, select “TCP/IP-Sales” as the connect device, select “Sales-IP” in “TCP/IP Group Name”, input “3” in address list.

6. Select menu “Communication Settings>New/Edit Group” to create a new group “All Signs”, and include site “R&D” and site “Sales” in this group.
7. Select menu “Send> Send Edit Area’s Content” to send message. It will display one dialog to let user select send message to which site or which group as follow:
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If you send message to sign 1# and sign 2# in R&D, first select the “Site” check radio button as above dialog, and then select site “R&D” in “Available Sites”.

If you send message to sign 1#, sign 2# and sign 3#, first select the “Group” check radio button as follows:
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Press “OK” button, program will send message to corresponding site(s) as follow:
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NOTE: 

If you have sent message to sign using V3.46 of this program or you have edit one or more schedules in sign, please don’t remove all files in the schedule using remote control, otherwise, the sign will collapse. If you want to remove all files or the sign has collapse, you can clear all memory of sign using this program (Select menu “Send>Clear Sign’s Memory”) to let the sign run normally.
3.4 How to Change the Langue of Program 
The default language of program is English, but you can translate all resources used by program to your native language, and then select menu “File->Language” to set one language as the default language of program.

All character string which program used are saved in “Multi_eng.ini” file, this file is in the “Language” sub-folder, now will introduce how to translate it:

· First, copy “Multi_eng.ini” to another file name, such as “Multi_French” if you want translates it to French.

· Second, open this file with Notepad.exe. (You can double-click this file in Windows Explore to open it.)

· This file’s content will look like as follows:

[Setting]

Language=English
[Dialog String]

IDD204_Title=Moving-Sign option

IDD204_1=OK

IDD204_2=Cancel

IDD204_1159=Please input the width of the Moving-Sign(UNIT: pixel)

IDD204_1004=The number of Moving-Sign inter-connected is 16

IDD204_1005=The number of Moving-Sign inter-connected is 128

IDD204_1160=Send option

IDD204_1158=Color

IDD204_1139=Single Color

IDD204_1140=Double Color
[Menu String]

IDS_MENU_0=File

IDS_MENU_1=Language

IDS_MENU_2=Clear

IDS_MENU_3=Open...(Ctrl+O)

IDS_MENU_4=Save(Ctrl+S)

IDS_MENU_5=Save As...

IDS_MENU_6=Exit
[String Table]

IDS_STRINGTABLE_32797=Send the edit area's message to the Moving Sign

IDS_STRINGTABLE_32798=Let user select a disk file and send it to the Moving Sign
There are four parts:

· The first part (red characters): This part is the markings to identify this file. Program will read this value (such as: English), and fill it to the list box when you select menu ‘File > Language’. So if you want translate English to the other language, such as French, you must modify the value of this part to French, now this part will look like:
    [Setting]
    Language=French
· The second part(green characters): All of these character strings in this part are used by dialog. 
· The third part (yellow characters): These character strings are menu character strings.
· The fourth part (blue characters): These character strings are used by program, such as, when program occur some errors, program will display a message box to tell user program occur what errors.

You must translate the second, third, fourth part to the other language, such as French, and then save this file.

At last, you run this program, select menu ‘File > Language’, it will display a dialog box, select the language you want from the list box, such as French, and then press ‘OK’ button, now program will display with French.
Note:

1. When user translates the second third, fourth, part, you only can modify the portion after equal mark, such as when you translate this character string as follow:
        IDD204_Title=Moving-Sign option
User only can modify the red characters.

2. User can’t edit or delete these characters as follows:
 \n, \t, \r, %d, %s
4. Statement 
Dear customers:

Thank you for purchasing this product！

For optimum performance and safety, please read these instructions carefully.

Before operating or adjusting this product, please read these instructions completely. Please keep this manual for future reference.

Changes
Our provides this manual ‘as is’ without warranty of any kind, either expressed or implied, including but not limited to the implied warranties or merchantability and fitness for a particular purpose. Our may make improvements and/or changes to the program(s) described in this manual at any time without notice.

This manual could contain technical inaccuracies or typographical errors. Changes are periodically made to the information in this manual; these changes are incorporated in new editions of this manual.

Warning 
    If non-our company’s equipment use our company’s software, the reliability general not be responsible.
The figure interface in this manual is for guide user while uses the program. Because all figure are cut figure, so it can’t display the content of interface legible. If user wants to read the legible content of interface, please according as your individuality defined to read the legible interface’s content.
Copyright 
All rights reserved. No part of this document may be copied, reproduced or translated. It shall not otherwise be recorded, transmitted or stored in a retrieval system without the prior written consent of us. 

If this manual’s content have any discrepancy with user has buy product’s software, our company retains the right of finally explain. 
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